Installing my SharePoint Virtual Machines on My New Dell M6700

I joined Dell recently and had to give up my previous laptop. I decided to purchase my own Dell M6700 mobile workstation to support my SharePoint virtual machines. The M6700 has the following hardware specifications:

 

CPU

Intel® Core™ i7-3840QM (3.80 GHz, 8MB L3, 1333MHz FSB)

Memory

32GB RAM (2 x Crucial CT3291640 16GB kit (8GBx2), 204-pin SODIMM)

Drive 1

256GB SSD

Drive 2

512GB SSD

Drive 3

128GB SSD

Optical Drive

Internal CD/DVD

SDHD Card

32GB Memory Card (if needed)

This is a slightly faster workstation in terms of CPU power. The real difference is that this workstation has 3 SSDs and still has a CD/DVD drive.

My plan was to move the VM images to the SDDs and run them. But it is never that easy. It seems that VMWare does not make it easy to move VM images that have two drives. I could not get the SQL Server VM to start up. I kept getting variations of the same error message. Basically, a file is missing and I cannot find it. I don’t think it ever really existed. I think that the problem is that I am not moving the files to the exact same disk drives.

 

error-msg

I finally gave up and reinstalled the SQL Server 2012 virtual machine. This time I installed it all in one drive. Besides, I have three SSDs – one for each VM! I run the Operating System and the domain controller VM on one SSD.

I had to load a snapshot of the SharePoint VM from just before the SharePoint software installation started. I still need to configure the Search features that I created in a later blog posting. But I have what I need for now! I will be taking this workstation with me for demos at conferences.

I also need to configure a backup drive for the backup software that I use.